Sep 222012

I was setting up my Gertboard this morning to shoot some video and noticed that when I put my hand near it, some of the LEDs come on. Further investigation revealed that the Gertboard was acting as a proximity sensor. I thought that was pretty cool. Have a look and see. Does yours do this too or have I made it wrong? ;)

Subsequently it was discovered that this is due to lack of pullup resistors on the self-assembly kit. The V2 assembled Gertboard launched in Jan 2013 has pullups, which is why the leds are on by default.

  18 Responses to “Gertboard is a proximity sensor”

  1. Yep – as mentioned on the forum, mine does that too!

    • Thanks for replying. :) Good – we can’t both have made the same random assembly error. I doubted it was an error, but you never know ;)

    • My Pre-built Rev 2 Gertboard does it too, I find it quite annoying to he honest, especially when I power up the boards all the LED’s come on, kind of makes the LEDs useless as status indicators.

  2. Mine does it too – I just thought it was down to my dodgy soldering skills!

  3. I assembled mine last week. Havent seen this effect, but doing the it is not lighting up 4 leds on the left of the board. Might be a program error but i think it is more likely i did something wrong during assembly…

    • That would be ports 25,24,23,22. I was going to ask if you were using a Rev 2 Pi, but having looked at the port changes, those four ports were unchanged on Rev 2. So either it’s a wiring issue or an assembly error. You have placed the jumpers on the OUT side of the buffer U3 for B1, B2, B3 & B4 I assume? If you forgot that, or put them on the IN side, those four would fail to light. (I wonder) ;)

      I don’t think it’s the software because other people have it working fine.

  4. [youtube

    I did all the tests in the manual (except ATmega tests) and this error is the only one coming up.

    Im quite sure i connected everything correctly according to
    In my head the error is due to some assembly mistake. Does anyone have a suggestion what i did wrong? ?:-)

    Options like
    Maybe the 4 leds are soldered the wrong way.
    Or due to the fact it is 4 of them not functioning, might there be something else i did not assemble the right way.

    • Check your solder joints on U3. Take the chip out first.. Another thing you could try is to swap the chip from one of the other buffers and see if that works. It could be chip failure – rare though. You’ve got the jumpers in place OK, so it must be something that affects all four of the leds on U3. It must therefore be either a joint on U3 or the U3 buffer chip itself. Let us know the outcome :)

      Or, as you say, all four leds the wrong way round.

      • Heh, funny thing happened.

        First i tried to change a chip like you suggested, same result.
        Then i tried to switch D1 to see if polarity was wrong. It did not light up when i started, but all the others did.
        I thought i corrected something by mistake unknowingly, so i switch back D1 to the polarity it had and now im back to the same result of not having D1-D4 working. :-?

  5. Why yes, if someone need any help building a spaceship with gertboard control im your man now

  6. I must be electric…

    Maybe that’s why part of your demo at the last CamJam didn’t work? ;-)

Leave a Reply